use strict;
my $str = '// YES
WFTDOC_TASK_DOCUMENT_V01
WFTASK_TASK_V01
// NO
[WFW].[WFLOW_WORKFLOW_V01]
WFW.WFTASK_TASK_V01
Workflow_DEV.WFW.WFTDOC_TASK_DOCUMENT_V01
WORKER_TOKEN_NR';
my $regex = qr/\b((?<!WFW\.|\[WFW\]\.\[)[A-Z_]+_V01)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}