re = /\b((?<!WFW\.|\[WFW\]\.\[)[A-Z_]+_V01)\b/
str = '// YES
WFTDOC_TASK_DOCUMENT_V01
WFTASK_TASK_V01
// NO
[WFW].[WFLOW_WORKFLOW_V01]
WFW.WFTASK_TASK_V01
Workflow_DEV.WFW.WFTDOC_TASK_DOCUMENT_V01
WORKER_TOKEN_NR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end