re = /(http|https)?\s*(:)?(\/\/)?\s*([a-z]{2,30}\s*)[.]*\s*([a-z]{2,30})\s*[.]\s*([a-z]{2,10})([\/]{0,1})/mi
str = 'Почты России- https :// www.pochta.ru/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end