$re = '/(http|https)?\s*(:)?(//)?\s*([a-z]{2,30}\s*)[.]*\s*([a-z]{2,30})\s*[.]\s*([a-z]{2,10})([/]{0,1})/miu';
$str = 'Почты России- https :// www.pochta.ru/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);