#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?miu)(http|https)?\s*(:)?(//)?\s*([a-z]{2,30}\s*)[.]*\s*([a-z]{2,30})\s*[.]\s*([a-z]{2,10})([/]{0,1})"
Local $sString = "Почты России- https :// www.pochta.ru/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")