package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(http|https)?\s*(:)?(//)?\s*([a-z]{2,30}\s*)[.]*\s*([a-z]{2,30})\s*[.]\s*([a-z]{2,10})([/]{0,1})`)
var str = `Почты России- https :// www.pochta.ru/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}