import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https)?\\s*(:)?(//)?\\s*([a-z]{2,30}\\s*)[.]*\\s*([a-z]{2,30})\\s*[.]\\s*([a-z]{2,10})([/]{0,1})";
final String string = "Почты России- https :// www.pochta.ru/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}