re = /[-*] \[[ xX]\] (?![ : ])/
str = '- [ ] : `Don\'t Merge` label is applied\\r
- [x] : `Don\'t Merge` label is applied\\r
- [X] : `Don\'t Merge` label is applied\\r
- [] : `Don\'t Merge` label is applied\\r
- [X] `Don\'t Merge` label is applied\\r
- [x] `Don\'t Merge` label is applied\\r
- [ ] `Don\'t Merge` label is applied\\r'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end