using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-*] \[[ xX]\] (?![ : ])";
string input = @"- [ ] : `Don't Merge` label is applied\r
- [x] : `Don't Merge` label is applied\r
- [X] : `Don't Merge` label is applied\r
- [] : `Don't Merge` label is applied\r
- [X] `Don't Merge` label is applied\r
- [x] `Don't Merge` label is applied\r
- [ ] `Don't Merge` label is applied\r";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}