#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[-*] \[[ xX]\] (?![ : ])"
Local $sString = "- [ ] : `Don't Merge` label is applied\r" & @CRLF & _
"- [x] : `Don't Merge` label is applied\r" & @CRLF & _
"- [X] : `Don't Merge` label is applied\r" & @CRLF & _
"- [] : `Don't Merge` label is applied\r" & @CRLF & _
"- [X] `Don't Merge` label is applied\r" & @CRLF & _
"- [x] `Don't Merge` label is applied\r" & @CRLF & _
"- [ ] `Don't Merge` label is applied\r"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")