$re = '/[-*] \[[ xX]\] (?![ : ])/';
$str = '- [ ] : `Don\'t Merge` label is applied\\r
- [x] : `Don\'t Merge` label is applied\\r
- [X] : `Don\'t Merge` label is applied\\r
- [] : `Don\'t Merge` label is applied\\r
- [X] `Don\'t Merge` label is applied\\r
- [x] `Don\'t Merge` label is applied\\r
- [ ] `Don\'t Merge` label is applied\\r';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);