import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[-*] \\[[ xX]\\] (?![ : ])";
final String string = "- [ ] : `Don't Merge` label is applied\\r\n"
+ "- [x] : `Don't Merge` label is applied\\r\n"
+ "- [X] : `Don't Merge` label is applied\\r\n"
+ "- [] : `Don't Merge` label is applied\\r\n"
+ "- [X] `Don't Merge` label is applied\\r\n"
+ "- [x] `Don't Merge` label is applied\\r\n"
+ "- [ ] `Don't Merge` label is applied\\r";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}