use strict;
my $str = 'xin chao (名画) taaat l l l L test Lã Quốc Nghị (nghilq) asdaw guyễn Đức Long (longnd) longChias Kazuma (名画)';
my $regex = qr/(?:(?<=[\s,.:;"']|^)\p{Lu}\p{Ll}+(?:[\s]\p{Lu}\p{Ll}+)*(?=[\s,.:;"']|$))|(?<=((?<=[\s,.:;"']|^)\p{Lu}\p{Ll}+(?:[\s]\p{Lu}\p{Ll}+)*(?=[\s,.:;"']|$))\s\()(?:\p{L}*?)(?=\))/mup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}