const regex = /(?:(?<=[\s,.:;"']|^)\p{Lu}\p{Ll}+(?:[\s]\p{Lu}\p{Ll}+)*(?=[\s,.:;"']|$))|(?<=((?<=[\s,.:;"']|^)\p{Lu}\p{Ll}+(?:[\s]\p{Lu}\p{Ll}+)*(?=[\s,.:;"']|$))\s\()(?:\p{L}*?)(?=\))/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<=[\\s,.:;"\']|^)\\p{Lu}\\p{Ll}+(?:[\\s]\\p{Lu}\\p{Ll}+)*(?=[\\s,.:;"\']|$))|(?<=((?<=[\\s,.:;"\']|^)\\p{Lu}\\p{Ll}+(?:[\\s]\\p{Lu}\\p{Ll}+)*(?=[\\s,.:;"\']|$))\\s\\()(?:\\p{L}*?)(?=\\))', 'gmu')
const str = `xin chao (名画) taaat l l l L test Lã Quốc Nghị (nghilq) asdaw guyễn Đức Long (longnd) longChias Kazuma (名画)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}