using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=[\s,.:;""']|^)\p{Lu}\p{Ll}+(?:[\s]\p{Lu}\p{Ll}+)*(?=[\s,.:;""']|$))|(?<=((?<=[\s,.:;""']|^)\p{Lu}\p{Ll}+(?:[\s]\p{Lu}\p{Ll}+)*(?=[\s,.:;""']|$))\s\()(?:\p{L}*?)(?=\))";
string input = @"xin chao (名画) taaat l l l L test Lã Quốc Nghị (nghilq) asdaw guyễn Đức Long (longnd) longChias Kazuma (名画)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}