import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=[\\s,.:;\"']|^)\\p{Lu}\\p{Ll}+(?:[\\s]\\p{Lu}\\p{Ll}+)*(?=[\\s,.:;\"']|$))|(?<=((?<=[\\s,.:;\"']|^)\\p{Lu}\\p{Ll}+(?:[\\s]\\p{Lu}\\p{Ll}+)*(?=[\\s,.:;\"']|$))\\s\\()(?:\\p{L}*?)(?=\\))";
final String string = "xin chao (名画) taaat l l l L test Lã Quốc Nghị (nghilq) asdaw guyễn Đức Long (longnd) longChias Kazuma (名画)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}