import Foundation
let pattern = ##"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[#$%/()=¿?*+-])(?=(?:([\w\d])\1?(?!\1\1)))(?!(?=.*(palabra1|palabra2|palabraN))).{8,20}$"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"mmholAhsbC123*"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"VALID PASSWORD"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}