const regex = /^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[#$%/()=¿?*+-])(?=(?:([\w\d])\1?(?!\1\1)))(?!(?=.*(palabra1|palabra2|palabraN))).{8,20}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*\\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[#$%\/()=¿?*+-])(?=(?:([\\w\\d])\\1?(?!\\1\\1)))(?!(?=.*(palabra1|palabra2|palabraN))).{8,20}$', '')
const str = `mmholAhsbC123*`;
const subst = `VALID PASSWORD`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);