using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[#$%/()=¿?*+-])(?=(?:([\w\d])\1?(?!\1\1)))(?!(?=.*(palabra1|palabra2|palabraN))).{8,20}$";
string substitution = @"VALID PASSWORD";
string input = @"mmholAhsbC123*";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}