$re = '/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[#$%/()=¿?*+-])(?=(?:([\w\d])\1?(?!\1\1)))(?!(?=.*(palabra1|palabra2|palabraN))).{8,20}$/';
$str = 'mmholAhsbC123*';
$subst = "VALID PASSWORD";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;