# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*\d)(?=.*[a-z])(?=.*[A-Z])(?=.*[#$%\/()=¿?*+-])(?=(?:([\w\d])\1?(?!\1\1)))(?!(?=.*(palabra1|palabra2|palabraN))).{8,20}$/VALID PASSWORD/;t' <<< "mmholAhsbC123*"