import Foundation
let pattern = #"^([a-zA-Z0-9_+-]+.{1})*[a-zA-Z0-9_+-]+@([a-zA-Z0-9_+-]+[.]{1})+[a-zA-Z]{1,5}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"se.l.89ene@gmailc.o.p.j.i"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}