using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9_+-]+.{1})*[a-zA-Z0-9_+-]+@([a-zA-Z0-9_+-]+[.]{1})+[a-zA-Z]{1,5}$";
string input = @"se.l.89ene@gmailc.o.p.j.i";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}