re = /^([a-zA-Z0-9_+-]+.{1})*[a-zA-Z0-9_+-]+@([a-zA-Z0-9_+-]+[.]{1})+[a-zA-Z]{1,5}$/i
str = 'se.l.89ene@gmailc.o.p.j.i'
# Print the match result
str.match(re) do |match|
puts match.to_s
end