import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z0-9_+-]+.{1})*[a-zA-Z0-9_+-]+@([a-zA-Z0-9_+-]+[.]{1})+[a-zA-Z]{1,5}$";
final String string = "se.l.89ene@gmailc.o.p.j.i";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}