import Foundation
let pattern = #"(7656119)([0-9]{10})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://steamcommunity.com/profiles/7656119xxxxxxxxxx OR 7656119xxxxxxxxxx
//steamcommunity.com/profiles/76561198253871432
765611982538714325 - false
7656119825387143288 -false
7656119825387143 - false
76561198253871432 -true
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)