const regex = /(7656119)([0-9]{10})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(7656119)([0-9]{10})', 'gm')
const str = `http://steamcommunity.com/profiles/7656119xxxxxxxxxx OR 7656119xxxxxxxxxx
//steamcommunity.com/profiles/76561198253871432
765611982538714325 - false
7656119825387143288 -false
7656119825387143 - false
76561198253871432 -true
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}