re = /(7656119)([0-9]{10})/m
str = 'http://steamcommunity.com/profiles/7656119xxxxxxxxxx OR 7656119xxxxxxxxxx
//steamcommunity.com/profiles/76561198253871432
765611982538714325 - false
7656119825387143288 -false
7656119825387143 - false
76561198253871432 -true
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end