package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(7656119)([0-9]{10})`)
var str = `http://steamcommunity.com/profiles/7656119xxxxxxxxxx OR 7656119xxxxxxxxxx
//steamcommunity.com/profiles/76561198253871432
765611982538714325 - false
7656119825387143288 -false
7656119825387143 - false
76561198253871432 -true
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}