using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(7656119)([0-9]{10})";
string input = @"http://steamcommunity.com/profiles/7656119xxxxxxxxxx OR 7656119xxxxxxxxxx
//steamcommunity.com/profiles/76561198253871432
765611982538714325 - false
7656119825387143288 -false
7656119825387143 - false
76561198253871432 -true
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}