re = /(<script[^>]*src=[\'\"](.*?)[\'\"].*?\>(<\/script>)?)/i
str = '<script type="text/javascript" src="https://www.google.com/jsapi1"></script><script type="text/javascript" src="https://www.google.com/jsapi4"></script><script type="text/javascript" src="https://www.google.com/jsapi3"/><script type="text/javascript" src="https://www.google.com/jsapi2"></script><script type="text/javascript" src="https://www.google.com/jsapi31"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end