#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(<script[^>]*src=[\'\"](.*?)[\'\"].*?\>(<\/script>)?)"
Local $sString = "<script type="text/javascript" src="https://www.google.com/jsapi1"></script><script type="text/javascript" src="https://www.google.com/jsapi4"></script><script type="text/javascript" src="https://www.google.com/jsapi3"/><script type="text/javascript" src="https://www.google.com/jsapi2"></script><script type="text/javascript" src="https://www.google.com/jsapi31"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")