import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<script[^>]*src=[\\'\\\"](.*?)[\\'\\\"].*?\\>(<\\/script>)?)";
final String string = "<script type=\"text/javascript\" src=\"https://www.google.com/jsapi1\"></script><script type=\"text/javascript\" src=\"https://www.google.com/jsapi4\"></script><script type=\"text/javascript\" src=\"https://www.google.com/jsapi3\"/><script type=\"text/javascript\" src=\"https://www.google.com/jsapi2\"></script><script type=\"text/javascript\" src=\"https://www.google.com/jsapi31\"/>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}