using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<script[^>]*src=[\'\""](.*?)[\'\""].*?\>(<\/script>)?)";
string input = @"<script type=""text/javascript"" src=""https://www.google.com/jsapi1""></script><script type=""text/javascript"" src=""https://www.google.com/jsapi4""></script><script type=""text/javascript"" src=""https://www.google.com/jsapi3""/><script type=""text/javascript"" src=""https://www.google.com/jsapi2""></script><script type=""text/javascript"" src=""https://www.google.com/jsapi31""/>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}