const regex = /(<script[^>]*src=[\'\"](.*?)[\'\"].*?\>(<\/script>)?)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<script[^>]*src=[\\\'\\"](.*?)[\\\'\\"].*?\\>(<\\\/script>)?)', 'gi')
const str = `<script type="text/javascript" src="https://www.google.com/jsapi1"></script><script type="text/javascript" src="https://www.google.com/jsapi4"></script><script type="text/javascript" src="https://www.google.com/jsapi3"/><script type="text/javascript" src="https://www.google.com/jsapi2"></script><script type="text/javascript" src="https://www.google.com/jsapi31"/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}