// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?(\bdocbox\b.*.pdf).+)$").unwrap();
let string = "Failed to move from wasbs:///docbox/7391167/26988/service_report/EDINBURGH CLINIC LTD_999002225876_20121019.pdf/2022-02-07 18:53:41.pdf to wasbs:///docbox/7391167/26988/service_report/2022-02-07 18:53:41/EDINBURGH CLINIC LTD_999002225876_20121019.pdf";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}