# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?(\bdocbox\b.*.pdf).+)$//gm;t' <<< "Failed to move from wasbs:///docbox/7391167/26988/service_report/EDINBURGH CLINIC LTD_999002225876_20121019.pdf/2022-02-07 18:53:41.pdf to wasbs:///docbox/7391167/26988/service_report/2022-02-07 18:53:41/EDINBURGH CLINIC LTD_999002225876_20121019.pdf"