$re = '/^(.*?(\bdocbox\b.*.pdf).+)$/m';
$str = 'Failed to move from wasbs:///docbox/7391167/26988/service_report/EDINBURGH CLINIC LTD_999002225876_20121019.pdf/2022-02-07 18:53:41.pdf to wasbs:///docbox/7391167/26988/service_report/2022-02-07 18:53:41/EDINBURGH CLINIC LTD_999002225876_20121019.pdf';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;