import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?(\\bdocbox\\b.*.pdf).+)$";
final String string = "Failed to move from wasbs:///docbox/7391167/26988/service_report/EDINBURGH CLINIC LTD_999002225876_20121019.pdf/2022-02-07 18:53:41.pdf to wasbs:///docbox/7391167/26988/service_report/2022-02-07 18:53:41/EDINBURGH CLINIC LTD_999002225876_20121019.pdf";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}