const regex = /^(.*?(\bdocbox\b.*.pdf).+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?(\\bdocbox\\b.*.pdf).+)$', 'gm')
const str = `Failed to move from wasbs:///docbox/7391167/26988/service_report/EDINBURGH CLINIC LTD_999002225876_20121019.pdf/2022-02-07 18:53:41.pdf to wasbs:///docbox/7391167/26988/service_report/2022-02-07 18:53:41/EDINBURGH CLINIC LTD_999002225876_20121019.pdf`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);