import Foundation
let pattern = #"(?P<name>post|get|url)\:(?P<data>(?:.(?!(et\:)|(ost\:)|(rl\:)))+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
dfkjsfkj dskljsdlfm sdfkjdsf sfsd get
asdkljasd,laosid post:
в
get:787wesdjdddddddddddddd hfsdfnxczp
url: oiwerweroi;get:787wesdjhfsdfnxczp
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)