$re = '/(?P<name>post|get|url)\:(?P<data>(?:.(?!(et\:)|(ost\:)|(rl\:)))+)/s';
$str = 'dfkjsfkj dskljsdlfm sdfkjdsf sfsd get
asdkljasd,laosid post:
в
get:787wesdjdddddddddddddd hfsdfnxczp
url: oiwerweroi;get:787wesdjhfsdfnxczp';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);