re = /(?P<name>post|get|url)\:(?P<data>(?:.(?!(et\:)|(ost\:)|(rl\:)))+)/
str = 'dfkjsfkj dskljsdlfm sdfkjdsf sfsd get
asdkljasd,laosid post:
в
get:787wesdjdddddddddddddd hfsdfnxczp
url: oiwerweroi;get:787wesdjhfsdfnxczp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end