using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<name>post|get|url)\:(?P<data>(?:.(?!(et\:)|(ost\:)|(rl\:)))+)";
string input = @"dfkjsfkj dskljsdlfm sdfkjdsf sfsd get
asdkljasd,laosid post:
в
get:787wesdjdddddddddddddd hfsdfnxczp
url: oiwerweroi;get:787wesdjhfsdfnxczp";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}