#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?P<name>post|get|url)\:(?P<data>(?:.(?!(et\:)|(ost\:)|(rl\:)))+)"
Local $sString = "dfkjsfkj dskljsdlfm sdfkjdsf sfsd get" & @CRLF & _
"" & @CRLF & _
"asdkljasd,laosid post: " & @CRLF & _
"в" & @CRLF & _
"get:787wesdjdddddddddddddd hfsdfnxczp" & @CRLF & _
"" & @CRLF & _
"url: oiwerweroi;get:787wesdjhfsdfnxczp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")