re = /[H\h]ello,? [W|w]orld!?/m
str = 'Hello, World! - Intended
hello, world! - Lower case
Hello World! - Forgot comma
Hello, World - Forgot exclamation point
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end