using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[H\h]ello,? [W|w]orld!?";
string input = @"Hello, World! - Intended
hello, world! - Lower case
Hello World! - Forgot comma
Hello, World - Forgot exclamation point
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}