$re = '/[H\h]ello,? [W|w]orld!?/m';
$str = 'Hello, World! - Intended
hello, world! - Lower case
Hello World! - Forgot comma
Hello, World - Forgot exclamation point
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);