#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[H\h]ello,? [W|w]orld!?"
Local $sString = "Hello, World! - Intended" & @CRLF & _
"hello, world! - Lower case" & @CRLF & _
"Hello World! - Forgot comma" & @CRLF & _
"Hello, World - Forgot exclamation point" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")