import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[H\\h]ello,? [W|w]orld!?";
final String string = "Hello, World! - Intended\n"
+ "hello, world! - Lower case\n"
+ "Hello World! - Forgot comma\n"
+ "Hello, World - Forgot exclamation point\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}